
CHAPTER 13

Presentation of results

Data presentation is the procedure by which information from a GIS is presented in a
form suitable for the user. Remember that the results of a GIS analysis are used in
planning and management. Normally, data analysis is not done by the decision 

makers and planners, therefore, information should be presented to them in such a
way that they are able to make sound decisions. If the information is presented to
them in a vague, unclear way, wrong decisions may be taken.

A map contains information, presented in a graphical form, intended for the map
user. A map is a means of communication, just as spoken text, video images, graphics
and sounds. A map should be well designed, so that the user can retrieve the
information quickly and easily. 

Although ILWIS is not a cartographic package, it does provide the basic tools for the
creation of annotation and to convert digital spatial data (maps) to a hard copy print.

In the first part of this chapter, an introduction is given to the use of color, both for
display on the screen and for printing. The second part of the chapter explains how to
produce an output map. The selection of colors, patterns and point symbols is
demonstrated, and the Layout editor is used to create a complete land use map. The
procedure for printing a map is shown after that, followed by the methods for
converting your data to other (cartographic) packages. The last part of this chapter
deals with the generation of demos in ILWIS.

Before you can start with the exercises, you should start ILWIS and change to the
subdirectory C:\ILWIS 3.0 Data\Users Guide\Chapter13, where the data files for
this chapter are stored.
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• Double-click the ILWIS icon on the desktop.

• Use the Navigator to go to the directory: C:\ILWIS 3.0 Data\Users Guide\
Chapter13.

☞



13.1  Introduction
When you prepare a map, you should be aware of the requirements of the map users.
A map intended for decision-makers, containing clear data without details, will be
very different from one made for scientists, which should contain as much factual
information as possible.

A map may be multi-purpose, such as a topographical map, which may be used by
many different people, for different purposes. A map can also be a single-purpose
map, displaying only one theme, for example, the annual rainfall distribution.

A map has a primary content (the main theme of the map), a secondary content (base
map information, such as roads, contours, drainage), and a supportive content
(legend, scale, north arrow, location map, etc.).

When you prepare a map for presentation you should decide on the scale of the map
you want to produce on paper. The scale of the output map should be based upon
considerations, such as: the purpose of the map (regional planning versus detailed
design), the requirements of the map user, the contents of the map, the size of the
area mapped, the size of the output map (paper format), and the required accuracy.

Displaying data to be used in the final map 

In ILWIS, the map making-process starts with the visualization of the mapped area
and the selection of the spatial and attribute data to be presented. You will first have
to investigate which data you want to display on your map as primary content (main
theme) and secondary content (base map information). Users should always be able
to locate themselves on a map, so each map should contain sufficient base map
information. On a large scale map, this base map information can be quite extensive
including contour lines, drainage lines, roads and other infrastructure, and the
location of villages and towns. On small scale maps, maybe only the main roads and
main towns can be displayed as base information. Putting too much base information
on a map is confusing.

It is possible to make use of one, or a combination of data layers (raster, segment,
polygon or point maps) to compile a final output map. In the Display Options -
dialog boxes, which appear just before a map is displayed in a map window, you can
specify how each map should be displayed.  

The objective of the exercises in this chapter is to produce a complete land use map.
The first step of the preparation process for producing an output map in this exercise,
is to display the map Landuse. Visualization of the map area is an important stage
in the preparation of the map for final printing, since further planning of the layout
can only be decided after viewing the map. For example, by visualization you are able
to check whether enough space is available for annotation or whether the map area
has to be extended and whether the contrast between colors representing different
mapping units is satisfactory or not. 
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In this exercise, the following data layers will be combined into a single map:

The polygon map Landuse: Forming the primary content. The map is displayed as
colored patterns.
- The point map Labels, containing text labels of the land use polygons.
- The raster map Shadows, containing the hillshading of the study area.
- The segment map Contour, containing the contour lines.
- The segment map Drainage, containing the drainage network.
- The segment map Roads, containing the road network.
- The point map Places, containing the location and names of the most important

locations in the area.

The various steps required to display maps and adding data layers to a map window
were explained in chapter 2.

The map Landuse is displayed in the map window. You can add several data layers
(polygon, segment and point maps) to this window, as long as they are using the same
coordinate system. 

It is clear that the complete map may become difficult to read because if you use all
layers as they are the map will contain too much base map information. Especially
the contour lines are too densely spaced. Later on, you will make a selection of the
contour lines.
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• Display polygon map Landuse.☞

• Close the map window when you have finished the exercise.☞

• Add the other data layers mentioned above to this map window: the segment
maps Contour, Drainage and Roads, the point maps Labels and
Places, and the raster map Shadows. Always use the default parameters in
the Display Options - dialog boxes.

☞



13.2  Colors
One of the most important aspects in the design of presentable maps is the selection
of the most appropriate colors.

In ILWIS, the colors of objects are defined in the representation. In chapter 2 several
aspects of representations were already discussed.

You will see a display of 20 colors. Every color may be seen as a combination of
different amounts of the primary colors: Red, Green and Blue (see Figure 13.1).

In ILWIS, you can work with three color systems (see Figure 13.1):
- The RGB (Red, Green, Blue) color system, which is used for display on most com-

puter screens.
- The YMC (Yellow, Magenta, Cyan) color system, often used to describe the color of

an image produced by several hard copy devices.
- The HSI (Hue, Saturation, Intensity) color system, used for image processing. 

In theory there is an infinite number of colors possible.  ILWIS uses contributions of
each of the colors Red, Green and Blue in the range from 0 to 255. A value of 255
refers to the full intensity of a basic color.

The notation: 
(0, 0, 0) returns black, (0, 0, 255) returns blue,
(255, 255, 255) returns white, (255, 255, 0) returns yellow,
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• Click with the right mouse button on representation Colors and select
Open from the context-sensitive menu. The Representation Class editor is
opened.

☞

Figure 13.1: Color systems. Left: The RGB color system. Right: The HSI color system.



(255, 0, 0) returns red, (255, 0, 255) returns magenta,
(0, 255, 0) returns green, (0, 255, 255) returns cyan.

Besides manipulation of colors in the representation of maps, ILWIS also has the
possibility to retrieve and/or assign colors in calculations. Calculations on colors
require maps or table columns with a color domain or a picture domain. You can also
see the color assignments of the items represented in the representation Colors in a
table.

Domain Color is a domain in which the colors are stored as Red, Green and Blue.
You can convert the colors as stated in the Color domain to the values of separate
Red, Green and Blue colors (or YMC or HSI as explained earlier) with a number of
statements (see Table 13.1). 

By using one of these statements you can either convert the colors in a representation,
shown as a table, using map calculation formulas, or you can use them on a map with
a color domain or picture domain.
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• Click on the color Yellow. You can see that the three slide bars on the left-
hand part of the window change. Red will be 255, Green will also be 255
and Blue will be 0. 

• Check the Red/Green/Blue components of the other 19 colors and close the
Representation Class editor afterwards.

☞

• Click in the Catalog with the right mouse button on representation Colors
and select Open as Table from the context-sensitive menu. The representa-
tion is now shown as a table.

• Double-click the column header Color. The Column Properties dialog box
is opened. As you can see, column Color has domain Color.

☞

Table 13.1: Expressions to convert a color domain into the
individual values of the color systems RGB, YMC
and HSI.

CLRRED (colorexpr) returns the red component 

CLRGREEN (colorexpr) returns the green component 

CLRBLUE (colorexpr) returns the blue component 

CLRYELLOW (colorexpr) returns the yellow component 

CLRMAGENTA (colorexpr) returns the magenta component 

CLRCYAN (colorexpr) returns the cyan component 

CLRGREY (colorexpr) returns the gray component 

CLRHUE (colorexpr) returns the hue component 

CLRSAT (colorexpr) returns the saturation component 

CLRINTENS (colorexpr) returns the intensity component  



Now you can see the 20 colors of the representation, expressed in the components of
the three color systems explained earlier. The first three columns Red, Green and
Blue, are simply the same values as in the appropriate part of the column color. The
second group of three columns (Yellow, Magenta, and Cyan) show the colors in
the YMC color system. Note that the calculation is made in the following way: 

Yellow = 255 - Blue
Magenta = 255 - Green
Cyan = 255 - Red

Next, there is a column showing the gray tones of the colors. The gray component is
useful when you want to produce a gray tone map out of a color map.

The last three columns (Hue, Sat, Intens) show the values according to the HSI
color system: 
- Hue is the direction of the color in a three-dimensional color cube; 
- Saturation is the purity of the color;
- Intensity is the brightness of the color. 

Note that the values for Hue, Saturation and Intensity range from 0 to 240, because
that is the standard HSI color range in Windows. For the exact conversion formulas,
see the ILWIS Help topic Color Separation. 
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• Close the Column Properties dialog box.

• Make the Command line appear in the table window by choosing the
Command Line from the View menu.

• Type the following formulas on the Command line and click OK each time
the Column Properties dialog box shows up:
Red = CLRRED(color) ↵
Green = CLRGREEN(color) ↵
Blue = CLRBLUE(color) ↵
Yellow = CLRYELLOW(color) ↵
Magenta = CLRMAGENTA(color) ↵
Cyan = CLRCYAN(color) ↵
Grey = CLRGREY(color) ↵
Hue = CLRHUE(color) ↵
Sat = CLRSAT(color) ↵
Intensity = CLRINTENS(color) ↵

☞

• Compare the values in the columns you have just calculated with the color
cubes in Figure 13.1 in order to get an idea of the three color systems.

• Close the table window.

☞



Hints for appropriate use of colors:

- For large areas in a map, the saturation of a color seemingly increases for the eye.
A color that looks okay in the legend may be too dominating in the map.

- Two rather similar colors can only be differentiated when they appear next to each
other in the map.

- Hues in the red-yellow region are said to be “warm colors”. Blue colors are said to
be “cold”.

- There are generally accepted color order scales. For example:
- Evidently: blue for water, green for vegetation, yellow for sandy areas.
- Some colors are more “powerful” and are used to indicate important features:

red for high hazard areas.
- To indicate increasing order scales, decreasing values are used: dark to light.

- It is not advisable to use more than 4 to 6 steps of the same hue.

- To indicate increasing positive and negative values use two base colors: red/yellow
& blue.

- The same colors are perceived lighter on a computer screen than on a paper map,
especially if you use high contrast and high brightness settings for your monitor.
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13.3  Editing visual variables 
13.3.1 Maps with a representation

A cartographer disposes of the following tools in the representation of information in
a map:
- The basic types of spatial data, mentioned in chapter 2: points, lines and areas.
- Volumetrical shapes, for example an impression of the relief shown with hill shading.
- Text for legend information, topographical information and codes of mapping units.
- Symbols related to points but also to other symbols such as pie charts or bar graphs

to display statistical information within mapping units.

To convey relevant information with these cartographic tools, a cartographer can use
several visual variables. With visual variables, one can manipulate how these above
mentioned items will be displayed. There are seven visual variables: position, form,
orientation, texture (variation of density of graphical elements with the same overall
gray expression), value (gray tones), size and color.

The visual variables that can be used in ILWIS depend on the map domain (class, ID,
value, picture, color), and on the type of map (point, segment, polygon and  raster).

When you make a division according to the type of maps, the following variables can
be used:
- Point maps. Point can be displayed with different symbol types from different 

symbol fonts. The size, line color, line thickness and fill color can be specified. 
- Segment maps. Segments can be displayed in different colors, line types (double,

triple, etc. for e.g. a highway) and different line widths.
- Polygon maps. Polygons can be displayed in different colors, either solid, hatching

or with a pattern, and the boundary lines around polygons can be shown in 
different colors and different line widths. 

- Raster maps. Raster maps can be displayed using different colors.

From point, segment and polygon maps, you can extract text labels which can use a
certain font type, size, color, etc. by creating an annotation text layer (see section
13.4).
For point (and raster) maps, you can also directly show texts via the map’s Display
Options - dialog box.

In chapter 2, the different types of representations that are available for different
domains were discussed. To summarize, the Representation editor can be used to
edit colors, patterns and point symbols of a map with: 
- Class domains: Colors and patterns can be assigned to the classes of the map.
- Value domains: For maps with a value domain you can have two types of represen-

tations:
- Representation Gradual, using percentage values as limits. This representation

can be used to display maps with any value domain.
- Representation Value, using actual values as limits. This representation can be

used only for the user-defined value domain for which it was created.
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- Identifier domains: Maps with domain type ID do not have a user-defined represen-
tation. They can be displayed:

- in 1, 7, 15, or 31 system colors via the Display Options - dialog box;
- by selecting a (class or value) column in the attribute table, e.g. in the Display

Options - dialog box.
- by calculating colors in a column with the color domain in the attribute table

(see paragraph 13.3.2).

In this paragraph you will edit visual variables through a representation. Table 13.2
shows for which type of maps and domains a representation is available. Identifier
domains and some system domains (Bit, Bool) do not have a stored representation on
disk. Editing visual variables if no representation is available will be discussed in
paragraph 13.3.2.

! For maps which use system domain Value, you can create a representation and
you can choose to work with either percentages (0-100%) or with values
(-99999.99 to 99999.99). 

Assigning colors to a class map

A map using a class or group domain always has a representation. Such a
representation can be edited in the Representation Class editor.  The colors,
patterns, line types, etc. of all classes in the map’s domain are shown and can be
changed in the editor.

This exercise shows how to change colors in a class map by editing its representation
class.

To change the colors of the mapping units:
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Table 13.2: Managing Colors for maps with different domains.

Type Domain Class Domain Identifier Domain Value

Point map Representation Symbols, Symbols by Attribute, Stretched Symbols
Class as Arrows, as Graphs

Segment map Representation 1, 7, 15, 31 Colors Representation
Class Value/Gradual

Polygon map Representation 1, 7, 15, 31 Colors Representation
Class Value/Gradual

Raster map Representation 1, 7, 15, 31 Colors Representation
Class Value/Gradual

• Display raster map Landuse.☞

• From the Edit menu, select the Representation command and select raster
map Landuse. 

☞



The Representation Class editor (Figure 13.2) is opened. The tabs in this
representation editor can be used to see the colors for raster, polygon, segment or
point maps using this class domain. In the central part of this window, the class
names and their colors can be viewed. In the upper left part just below the Toolbar of
the window you will see the Color Selector and in the lower left part the Red,
Green and Blue Color Sliders are visible. 

Colors can be edited in various ways:
- double-clicking classes;
- selecting a class and using the Color Selector;
- selecting a class and using the Color Sliders;
- selecting multiple classes and edit multiple items;
- assigning custom colors to a class.

In this exercise you will produce a simplified land use map based on the main land
use classes of Cochabamba.

! When you change the color of a class in a representation class, the color of this
class will also be changed in all other maps that use the same domain and thus the
same representation.
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Figure 13.2: The Representation Class editor showing the Raster, Polygon, Segment and Point
tabs, the Color Selector (upper left part) and the Color Sliders (lower left part).



! Any changes are directly saved to disk.

The selected class is shown as text at the top of the dialog box. The color list box
displays a number of pre-defined colors. If you want to select your own color, you
can click the Custom Color button; then the custom Colors dialog box appears. You
can also double-click Custom at the bottom of the list of colors.

The standard Windows Color dialog box (see Figure 13.3) provides another way to
create an appropriate color for a class. The pre-defined colors are shown in the group
Basic colors. You can make a new color by clicking the Define Custom Colors >>
button, dragging the cursor in the Color Refiner box, and adjust the brightness in the
bar next to it. You can also enter the color as values of Hue/Saturation/Luminosity
(=Intensity), or as Red/Green/Blue. When you are satisfied with a certain color, you
can press the Add to Custom Colors button: the new color will be added to the
selected box in the Custom colors palette.
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• Select the class Bare rock.

• Use the Red, Green and Blue Color Sliders to compose the correct color
for this class.

• Move the Red (color) scroll bar to value 84.

• Move the Green (color) scroll bar to value 84.

• Move the Blue (color) scroll bar to value 84.

• Select the class Agriculture(irrigated).

• Change the colors to: Red = 0, Green = 176 and Blue = 20.  

• Double-click the class Forest. The Edit Repr. Item dialog box is opened. 

☞

• Select the color ForestGreen and click OK.

• Double-click the class Urban centre. The Edit Repr. Item dialog box is
opened again. 

• Click the Custom Color button. The Color dialog box is opened.

☞

• Press the Define Custum Colors >> button.

• In the Color Refiner box, select a reddish color along the left-hand side
(Red = 195, Green = 35 and Blue = 35). Click the button Add to Custom
Colors and click OK in the Color dialog box. 

• Now you are back in the Edit Repr. Item dialog box. Click OK. This will
bring you back to the Representation Class editor.

☞



Now, you will edit the colors for the various mapping units.
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Figure 13.3: The standard Windows Color dialog box.

• Edit the Red, Green, and Blue colors of each class according to the colors in
Table 13.3. 

• Click the Redraw button in the map window to see the result.

☞

Table 13.3: Colors of the land use units.

Class Color Name Red Green Blue Hatching polygons

Agriculture Green 0 255 0 Horizontal

Agriculture (irrigated) LimeGreen 0 176 20 Vertical

Airport Red 255 0 0 Upwards

Bare rock DimGray 84 84 84 Solid

Bare soils LightGray 68 168 168 Solid

Forest ForestGreen 48 128 76 Solid

Grassland Custom 159 255 0 Solid

Lake Custom 0 146 255 Solid

Riverbed Custom 182 182 255 Solid

Shrubs Custom 106 126 0 Solid

Urban centre Custom 195 35 35 Diagonal

Urban periphery Custom 129 40 0 Crossing



Unit hatching

Besides colors, the Representation Class editor contains a number of hatching
types which can be used to represent units in a polygon map. 

Note that there is now an extra option Hatching in the lower part of the dialog box.
With this option, you are able to select a hatching type and/or a background color for
a selected class.

Note that hatching is only possible for polygon maps.

Visual variables for segments: color, line type and line width

The visual variables for segment maps are color, line type and line width. For the
production of the final map you will need three segment maps: Contour,
Drainage, and Roads. The first map is a value map and the other two are class
maps.
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• Add polygon map Landuse to the map window and switch off the raster
layer in the map window.

• In the Representation Class editor, click the Polygon tab. 

• On the Polygon tab, double-click class Urban centre. The Edit Repr.
Item dialog box is opened.

☞

• Select the Hatching type Diagonal and click the OK button.

• Set the hatching of the other classes as indicated in Table 13.3.

• Press the Redraw button in the map window to see the result.

• Close the Representation Class editor and the map window when you have
finished the exercise.

☞

• Open segment map Drainage. 

• Double-click the word ‘Legend’ in the Layer Management tree of the map
window to open the Representation Class editor.

• Double-click the item Main river. The Edit Repr. Item dialog box is
opened.  Change the Line width to 0.2 and the Color to Blue. 

• Change the Color of the item Drainage to Blue, and the one of the item
Lake to Cyan. Leave the Line width 0 for these two.

• Click the Redraw button in the map window, look at the result and close the
Representation Class editor. 

• Add segment map Roads to the map window.

☞

➥



The segment map Contour has a value domain Height, which also has a value
representation Height. However, we do not want to display the contour lines in
different colors. They should be shown in gray, and we want to display only the main
contour lines (those every 100 meters).

Visual variables for point maps

Data such as the location of villages and towns or data that are aggregated to points,
such as total population per province, can be symbolized as points. Points are
visualized as symbols, but they may vary in size according to the quantity they
represent. Different simple point symbols are supported (circle, square, diamond,
plus, etc.); you can also choose another symbol font.

Point data presented in a point map with a domain type class can be symbolized by
editing the representation linked to the map. Point maps with the domain type
identifier or value are linked to a system representation; the process of symbolizing
the point data has to be done using the Display Options – Point Map dialog box. 

In this part of the exercise, the point map Places with class domain is used. By
editing the representation used by this map, you are able to select symbol type,
symbol, size, fill color, line width and line color for the individual points in the map.
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• Similarly, change the representation of the segment map Roads. Change the
Color of item Main roads to Red, Line Type to Double and the Line
width to 0.2. Change the Color of Secondary road to Red.

• Click the Redraw button in the map window and close the Representation
Class editor after you have seen the result.

➦

• Drag-and-drop the segment map Contour to the map window. The Display
Options – Segment Map dialog box is opened.

• Select the check box Mask and type the following mask: ??00. This will
result in the display of the 100 meter contour lines only.

• Click the option Single Color and select the color Gray. Click OK.

• Close the map window after you have seen the result.

☞

• Display point map Places.

• In the Layer Management pane, double-click the name Cerveceria
Taquina (the local beer brewery). The Edit Repr. Item dialog box is
opened.

• Specify Symbol Square, Size 4, Fill Color Yellow, Line Width 1 and
Color Red for this point and click OK to see the result.

☞

➥



! You can also create an annotation text object (see section 13.4) which can be
based on a map. In this way you obtain all class names, IDs, or values of the
points in your map, while you can edit the exact positions, fonts, font sizes, etc. of
the texts later on in the Annotation Text editor.

13.3.2  Maps without a representation

In the previous paragraph, you have seen how to edit visual variables through a
representation. The visual variables that can be changed are subject to the type of
map and to the map’s domain. In this paragraph, you will see how to change visual
variables of maps without a user-defined representation. 

Point map with a value domain: temporary stretching

For point maps with a value domain, you can specify symbol type, color, line width
and line color for all points. For interpretation purposes, a point map with a value
domain can be displayed using a stretch option for the symbol size. There are two
stretch methods available: Linear and Logarithmic. If this is applicable to the type of
symbol, you can either stretch the Radius or Area of a symbol. A stretch range can
be specified as lower and upper boundaries. 

Point map Rainfall has an identifier (ID) domain. The map is linked to an attribute
table which contains rainfall data per year (Total), per quarter and per month. In
this exercise you will display an attribute point map Rainfall with the point radius
stretched according to the total annual rainfall. 
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• Specify the symbol representation for the other points according to Table
13.4.  

• Close the map window when you have finished the exercise. 

➦

Table 13.4: Symbol representation for the point map places.

Symbol Type Symbol Size Fill Color Line Width Color

Cerveceria Taquina Simple Square 4 Yellow 1 Red

Cochabamba Simple Circle 6 Red 2 Black

Laguna Largon Mayu Simple Diamond 4 White 2 Blue

Airport Wingdings � 8 Red

• In the Catalog, double-click point map Rainfall.

• In the Display Options – Point Map dialog box, select the Attribute check
box, and select column Total.

• Click the Symbol button. The Symbol dialog box is opened.

☞

➥



Point map with an ID domain: points as graphs

When the attribute table of an ID point map contains comparable value columns of
various categories, you can display the points as graphs. In the Symbols as Graphs
dialog box, you can specify the type of graph: 
- Pie Chart
- Bar Graph
- Line Graph
- Composed Bar
- Volume Cubes

The values of the selected columns will be represented by the size, length, volume,
etc. of the selected graph type. For pie charts, you can also specify a stretch and
stretch range of the total size of the pie charts. This is a useful option when the total
size of the pie charts should represent the total amount of all variables depicted in the
pie charts.  As an alternative, you can also specify a fixed, user-defined size for all
pie charts.
For more information on this subject, see the ILWIS Help topic Symbols as
graphs: Point maps with ID domain and attribute table.

In this exercise, you will use a pie chart to display rainfall data of one year for the
Cochabamba area. To reduce the number of wedges in the pie chart, you will
represent the total rainfall per quarter. The stretch option will be selected to display
the size of the pie charts according to the total annual rainfall. The raster map
Shadows will be used as a background map.

ILWIS 3.0 User’s Guide

Presentation of results

494

• Accept the defaults for Symbol Type, Symbol, Fill Color, Line Width and
Color.

• Select the Stretch check box and accept the default stretch range.

• Accept Linear and Radius for the stretch method and click OK in the
Symbol dialog box.

• Click OK in the Display Options - Point Map dialog box. Point map
Rainfall is now displayed with a point radius proportionally to the total
annual rainfall.

➦

• In the Catalog, double-click raster map Shadows. In the Display Options
– Raster Map dialog box, select the option Light and click OK. The raster
map Shadows is displayed. 

• Drag and drop point map Rainfall into this raster map window. The
Display Options - dialog box of point map Rainfall is opened.

• In the Display Options – Point Map dialog box, select Symbols as
Graphs and click the Details button. The Symbols as Graphs dialog box
appears.

☞

➥



The points are displayed as pie charts, showing the rainfall values per quarter. The
total size of each pie chart is proportional to the total annual rainfall at that location.
If you like, repeat the exercise and try other possibilities like Compose Bar and/or
Line Graphs.

User-defined coloring of maps with an ID domain

In general, maps with an ID domain are displayed with a system representation. Units
are represented in a fixed number of system colors (1, 7, 15 or 31 colors) that cannot
be assigned to specific map elements (domain items). However, in most cases, you
will wish to show an attribute value of the ID map.

In case, you really wish to show the mapping units as IDs themselves, you can use in
the attribute table of the ID map some table calculations: for each ID a different color
will be generated. The colors will be stored in an attribute column with the color
domain. 

Every color may be seen as a combination of different amounts of the primary colors
Red, Green and Blue. The easiest way to create distinct colors for all domain items is
to use a formula that will assign random colors to the domain items. Another option
is to enter values for Red, Green and Blue manually. For more information, see ILWIS
Help, topic Table calculation, Calculations on colors.

In this exercise, you will create a user-defined representation for polygon map
Cityblock, which has an ID domain. You will create a new column with a color
domain in the attribute table, and calculate random colors for all city blocks. To
display the polygon map Cityblock with the new distinct colors, you need to select
the option Attribute Column in the Display Options – Polygon Map dialog box.
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• Make sure that the option Pie Chart is selected. 

• From the left hand list box, select the columns Quarter1, Quarter2,
Quarter3 and Quarter4. Use the Ctrl or Shift key to select multiple
columns and press the > button. The right hand list box now lists the selected
columns from which the graphs will be constructed. 

• Select the Stretch check box and select column Total.

• Type 6 for the minimum and 14 for the maximum piechart Size.

• Accept the Radius option as stretching method and click OK. You are back
in the Display Options – Point Map dialog box.

• Click OK. The point map Rainfall is now displayed on top of the raster
map Shadows. 

➦



In column Random, you will see the newly calculated values Red, Green and Blue.
The formula returns a color composed by the random RND function, resulting in
random values for Red, Green and Blue (each ranging from 0 to 255).

You can now display polygon map Cityblock by its attribute column Random. 

Polygon map Cityblock is now displayed with random colors for all map units. If
necessary, you can change individual colors manually. This map could be saved as a
map view and used to create a layout. 

Summary: Editing visual variables
- The visual variables that can be used in ILWIS depend on the one hand on the

domain of the map (class, ID, value, picture, color) and on the other hand on the
type of map (point, segment, polygon and raster).

- When you make a division according to the type of maps, the following variables
can be used:

- Point maps. Point can be displayed with different symbol types from different
symbol fonts. The size, line color, line thickness and fill color can be specified. 

- Segment maps. Segments can be displayed in different colors, line types (dou-
ble, triple, etc. for e.g. a highway) and different line widths.

- Polygon maps. Polygons can be displayed in different colors, either solid, hatch-
ing or with a pattern, and the boundary lines around polygons can be shown in
different colors and different line widths. 

- Raster maps. Raster maps can be displayed using different colors.

- From point, segment and polygon maps, you can extract text labels which can use a
certain font type, size, color, etc. by creating an annotation text layer. For point (and
raster) maps, you can also directly show texts via the map’s Display Options - dia-
log box.

- The ILWIS Representation editor can be used to edit colors, patterns and point
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• Open the table Cityblock.

• Type the following formula on the Command line of the table window:
Random:= COLOR(RND(255),RND(255),RND(255)) ↵

• In the Column Properties dialog box accept Domain Color and click OK.

☞

• In the Catalog, double-click polygon map Cityblock. 

• In the Display Options – Polygon Map dialog box, select the Attribute
check box, select column Random and click OK. 

☞

• Close the table and the map window. ☞



symbols of a map with: 
- Class domains: Colors and patterns can be assigned to the classes of the map.
- Value domains: For maps with a value domain you can have two types of repre-

sentations:
- Representation Gradual, using percentage values as limits. This representa-

tion can be used to display maps with any value domain.
- Representation Value, using actual values as limits. This representation can

be used only for the user-defined value domain for which it was created.
- Identifier domains: Maps with domain type ID do not have a user-defined rep-

resentation. They can be displayed:
- in 1, 7, 15, or 31 system colors via the Display Options - dialog box;
- by selecting a (class or value) column in the attribute table, e.g. in the

Display Options - dialog box.
- by calculating colors in a column with the color domain in the attribute table

(see paragraph 13.3.2).

- Editing visual variables of maps without a user-defined representation:
- Point maps with a value domain. For interpretation purposes, a point map with

a value domain can be displayed using a stretch option for the symbol size.
- Point maps with an ID domain. When the attribute table of an ID point map

contains comparable value columns of various categories, you can display the
points as:

- Single Symbol;
- Symbols by Attribute;
- Symbols as Arrows, or
- Symbols as Graphs.

- User-defined coloring of maps with an ID domain. If you prefer to display an
ID map in a user-defined way, instead of using system colors, you can calculate
for instance random colors in a column in the map’s attribute table. The column
should use the color domain.
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13.4  Map views
Combining data layers

In the previous section you have learned how the individual data layers, that will form
part of the final map, can be best displayed. A data layer is a raster, polygon, segment
or point map, for which the user has specified display options such as color, width,
size, etc., for the display in a map window. In this exercise you will combine various
data layers into a single ‘map’. The combination of data layers will be stored as a
map view. 

A map view may contain data layers, annotation text layers, grid lines and/or
graticules. The display settings (colors, widths, etc.) of each layer is stored. By
opening a map view, all layers that were stored in the map view will be displayed
exactly as they were stored, i.e. same colors, same zoom factor, same area. The title
that you give to a map view, is later visible in the Title bar of the map window. 

In this exercise, the following data layers will be combined into a single map:
- Polygon map Landuse: Forming the primary content. The map is displayed as col-

ored patterns.
- Raster map Shadows, containing the hillshading of the study area.
- Segment map Contour, containing the contour lines.
- Segment map Drainage, containing the drainage network.
- Segment map Roads, containing the road network.
- Point map Places, containing the location and names of the most important loca-

tions in the area.
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• Double-click raster map Shadows in the Catalog. The Display Options
dialog box is opened.

• Select the Light option and click OK in the Display Options – Raster
Map dialog box. The map is displayed.

• On the Toolbar of the map window, click the button Add Layer. The Add
Data Layer dialog box is opened. 

• Select the polygon map Landuse and click OK. The Display Options -
Polygon Map dialog box is opened. 

• Accept the defaults and click OK. The polygon map Landuse is added to
the list of data layers.

• Click the Add Layer button again and select segment map Contour in the
Add Data Layer dialog box. 

• Click OK. The Display Options – Segment Map dialog box is opened.

• Select the Mask check box and type the following mask: ??00.

• Select the Single Color option and select the color Brown. 

• Click OK in the Display Options – dialog box. The map Contour is now
displayed and added to the list of data layers.

☞

➥



Now all added layers are displayed in the map window. Furthermore, all layers appear
in the Layer Management pane (left hand side of the map window). 

Adding an Annotation Text layer

You can also add text layers by creating a new object called annotation text. An
annotation text layer is designed to display and store multiple texts at multiple
positions. An annotation text object can be based on an existing point, segment, or
polygon maps. If you do so, the text object will contain a text (class name, ID or
value) for each point, segment or polygon in the selected map.  In the next exercise
you will create text labels for point map Places. 

The Annotation Text editor allows you to edit text items stored in an annotation text
object. With the Annotation Text editor, you can:
- insert new texts and delete selected existing texts, 
- move one or more selected texts to another position, 
- make text duplicates, and 
- specify fonts, sizes, colors, etc. for (multiple) selected texts. 

In this case, we will only change the font and the font size of all text labels.
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• Add segment maps Drainage and Roads and point map Places to the
same map window; use default Display Options.

➦

• From the File menu in the map window, select Create and select
Annotation Text. The Create Annotation Text dialog box is opened. 

• Enter the AnnText Name: Place_labels.

• Make sure the check box Based on Map is selected and choose point map
Places from the drop-down list box.

• Accept all other defaults and click OK. The Annotation Text editor is
opened.

☞

• From the Edit menu, choose Select All. In the map window, you will see
that all the text labels are selected. 

• Click the right mouse button in the map window and select Edit from the
context-sensitive menu. The Edit Texts dialog box appears. 

• Select the Font Name Arial and type 8 for the Font Size. 

• Select Text Color Blue, deselect the Transparent check box, accept all
other defaults and click OK. The annotation text labels appear in blue on top
of the point symbols.

• Move the text labels one by one to a position you like and click the Exit
Editor button in the Toolbar after you are satisfied with the result.

☞



The text labels are displayed with the new font and font size. For more information of
using the Annotation Text editor, refer to the ILWIS Help.

! Advanced users may prefer to edit an annotation text object in table form. This
may provide quicker, easier or more precise possibilities to edit texts, positions
and other settings like font, font sizes, colors, etc. To open an annotation text
object as a table, you can double-click the object in the Catalog or open the File
menu in the Main window, choose Open As Table and select an annotation text
object.

Adding grid lines

Grid lines are regularly spaced, horizontal and vertical on a map area, according to
the coordinate system linked to the map. In this exercise, grid lines are added to the
data layers in the map window.

Saving as map view

Now you can save the map window with all data layers, the annotation text layer and
the grid lines in a map view.

ILWIS 3.0 User’s Guide

Presentation of results

500

• From the Layers menu, select the Add Grid Lines command. The Display
Options - Grid dialog box is opened.

• Type 5000 in the Grid Distance text box, accept Line Type Single and
select Yellow from the Color list box.

• Click OK in the Display Options Grid – dialog box. The grid lines are
added to the map window.

☞

• From the File menu in the map window, select the Save View As command.
The Save View As dialog box is opened.

• Enter the Map View Name: Landview.

• Enter the Title: Landuse map of the Cochabamba area.

• Click OK. The view is now saved.

• Close the map window.

• Open the map view Landview. As you can see, all layers that you combined
earlier are now appearing in the same way as you displayed them before.

• Close the map view afterwards.

☞



Summary: Map views

- A map view contains the names of all layers to be displayed in one map window
including the display settings (the colors, widths, etc.) of these layers.

- Besides data layers (maps), you can also add annotation text objects, grid lines or
graticules to a map window. These layers can also be saved in the map view.

- The title that you give to a map view, is later visible in the Title bar of the map
window. If you save a map view when zoomed in on a map, the zoomed area will
be displayed when opening the map view.
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13.5  Layout and Annotation
A map has a primary content (the main theme of the map), a secondary content (base
map information, such as roads, contours, drainage), and a supportive content
(legend, scale, north arrow, location map etc.). In the previous exercise you have
generated a map view (Landview) containing the primary content (Landuse
polygon map), the secondary content (raster map Shadows, segment maps
Contour, Drainage and Roads, and point map Places) and a supportive content
(annotation text labels (Place_labels), grid lines). In this exercise you will see
how you can add other supportive content (annotation) by creating a layout.

A layout is required to print maps with annotation. A layout is a virtual sheet of paper
on which you can make a composition of one or more map views into which you can
insert annotation. For each map view, you can specify the scale on which the map
view has to be displayed and printed later on. 

A layout may contain:
- One or more map views, each of which may include a raster map, and multiple

polygon, segment or point maps, annotation text layers, grid lines and/or a 
graticule;

- Texts;
- Boxes;
- Pictures and/or bitmaps.

For each map view, you can add in the layout:
- A legend for each layer in a map view;
- A scale bar and scale bar text;
- A north arrow;
- A map border, including coordinates and ticks for grid lines and or a graticule.

Pictures or bitmaps can be inserted from the clipboard or from harddisk. Annotation
can be edited by double-clicking the object in the Layer Management pane. The
total composition of the map view(s) added annotation should be saved in the layout.
This layout can be printed later on.

In this exercise you will create a layout for the land use map of the Cochabamba area.
The final map that will be made is shown in Figure 13.4.

Creating a Layout

The Layout editor contains a Layout Management pane and a Layout pane. The
Layout Management pane lists the inserted layout items, showing their icon, name,
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• From the File menu of the Main window, select Create, Layout. The Layout
editor is opened.

☞



position, size and scale. In the Layout pane itself, the paper and its margins are
visible. 

! You can also start to create a layout by choosing the Create Layout command
from the File menu in the map view window or by clicking the right mouse button
on a map view in the Catalog and choosing Create Layout from the context-
sensitive menu.

In this stage of creating a layout, you can change the Page Setup and choose Paper
Size, Orientation (Portrait or Landscape) and Margins. The page setup can still
be changed later, if needed. You will alter the Orientation of the paper into
Landscape now.

Layout elements, such as map views, legend, scale bar, north arrow, etc., can be
added to the virtual paper using the Insert menu or by using the following buttons in
the Layout toolbar of the Layout editor:

to add a Map View to add a Scale Bar

to add simple Text e.g. a title to add a Scale Text

to add a Box to add a layer to a map view

to add a Picture or bitmap from disk to remove a layer from a map view

to add a Legend to add Grid Lines to a map view

to add a Map Border to add a Graticule to a map view

to add a North Arrow

Inserting a map view

Map views are the primary contents of a layout (see section 13.4 for how to make a
map view). You can insert multiple map views in a single layout. In this exercise you
will only use one map view Landview.
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• From the File menu of the Layout editor, select Page Setup. The Page
Setup dialog box is opened. 

• Make sure the Paper Size is A4, change the Orientation to Landscape
and click OK. The orientation of the layout is now changed into landscape.

☞

• From the Insert menu, select Map View. You can also click the Map View
button in the Layout toolbar. The Insert Map View dialog box is
opened. 

• Select Landview and click OK. The Set Scale dialog box appears.

• Change the scale into 1:150000 and click OK. The map view Landview is
now listed in the Layout Management pane and displayed in the Layout
pane. 

☞



In the Layout pane, you can position the map view by dragging it, size the map view
by dragging one of its size handles or zoom in into a specific area and/or pan to the
desired area.

The same operation can be carried out in the Layout Management pane. Select a
field in the Layer Management pane and edit the value of the field: position, size,
scale, etc. 

The map is now displayed on scale 1:125000. For A4 paper size, this is a reasonable
scale to print the map later on.  You can fix this scale.

In principle, the scale of the map view is now fixed to 1:125000. When the size
handles of a map view are dragged by accident, nothing will happen. When you make
the map view smaller by dragging its size handles to the inside the map view will
become smaller, but the scale on which the map view is displayed remains the same.
Only part of the map view will be shown. 

You can still change the scale of the map view manually by typing a scale in the
Layout Management pane. 

Creating a map border

With the Map Border option, you can add border information to a map, optionally
displaying: neat line graduation, grid and/or graticule ticks, grid coordinates, gratic-
ule and/or corner coordinates, map outline.
Here, you will add a neat line, grid ticks and grid coordinates to the map view.
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• In the Layout pane, click the map view Landview, hold down the mouse
button and drag the map view to the left side of the paper (see Figure 13.4). 

• Before you can size or pan you must deselect the Keep Scale option by
opening the View menu and deselecting Keep Scale or by clicking the
Keep Scale button in the Standard toolbar (the button should appear
up). Try to size and/or pan the map view, but in the end make sure to display
the entire map.

☞

• In the Layout Management pane, click the Scale field of the map view
Landview.

• Change the scale into 1:125000.

• If necessary, position the map view again.

☞

• Make sure the map view Landview is selected in the Layout pane.

• From the View menu, select the Keep Scale command or click the Keep
Scale button in the Standard toolbar (the button should appear down).

☞



Creating a legend 

A legend is created based on information available in the domain of a map in a map
view and the representation used by the domain. In this exercise, a legend is created
for the map Landuse and this legend is added to the map view Landview that is
displayed in the layout. 

The Map Layer Selection dialog box is opened. It enables you to select a layer for
which the legend will be created.
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• Make sure the map view Landview is selected in the Layout pane.

• From the Insert menu, select Map Border or click the Map Border button
in the Layout toolbar. The Edit Map Border dialog box is opened. 

• On the Grid tab, select the Grid Ticks check box and type 5000 for the
Interval and type 1.0 for the Tick Length.

• Select the Grid Coordinates check box and type 5000 for the Interval. 

• Select Full Coordinates and Text Offset 2.0 mm. 

• Select the Font Name: Times New Roman and Font Size: 10.

• Click OK. The map border is displayed in the layout window.

• Position the map view in such a way that the map view and coordinates are
displayed within the page margins.

☞

• Make sure the map view Landview is selected in the Layout pane.

• From the Insert menu, select Legend. You can also click the Legend button
in the Layout toolbar.

☞

• Select polygon map Landuse and click OK. The Display Options –
Legend dialog box is opened.

• Select Font Name: Times New Roman, and Font Size: 10. 

• Accept the defaults for other display options by clicking the OK button. The
legend will be displayed in the Layout pane.

• Select the legend box.

• Drag the box to the right hand side of the layout (see Figure 13.4). Leave
some open space below the legend, so that the scale bar can be placed there.

• Repeat the previous steps to insert a legend for the Drainage and Road
data layers.

☞



! You can align the separate legend items by typing identical values for Left and/or
Top position in the Layer Management pane.

Save the layout before proceeding. 

Adding an inset map or picture

Graphics may be inserted into the layout. You can add pictures and/or bitmaps, which
have been copied to the Clipboard before and paste them in the layout (copy and
paste one by one). You can also insert picture and/or bitmap files. Pictures, also
called Windows Meta Files, have extension WMF; bitmaps have extension BMP.

First, a bitmap of Bolivia will be added to the map window.
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• From the File menu, select Save As. The Save As dialog box appears. 

• Type Landview for the File name and click Save.

☞

Figure 13.4: The land use map that will be made in this exercise.

• From the Insert menu, select Bitmap/Picture or click the Bitmap/Picture
button in the Layout toolbar. The Insert Bitmap or Picture dialog box
is opened.

• Select the bitmap Bolivia and click OK. The Bolivia map is displayed in
the layout.

☞

➥



It is also possible to paste a picture from the Clipboard into the layout.

To paste the bitmap into the layout:

Adding text
In general, a map has a title, which gives a description of its contents. This exercise
shows how to create a title and how to position it in the layout. 

If you select in the Edit Text dialog box the option Transparent, the background
color of the text area (white) will not be shown. This is important when the text has to
be placed on mapping units.
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• Drag the Bolivia map and position it somewhere at the right hand side of
the layout (see Figure 13.4).

• Size the inset map by dragging its corner handles.

• Save the layout.

➦

• Open the file ITClogo.bmp in a drawing program (e.g. Microsoft Paint).

• In Microsoft Paint, open the Edit menu and choose Select All. 

• Open again the Edit menu and choose the Copy command. The bitmap is
now copied to the Clipboard.

• Close the Microsoft Paint program.

☞

• Activate the Layout editor and select the Paste command from the Edit
menu or use the Paste button in the Standard toolbar. The ITClogo is
now pasted into the layout.

• Click the ITClogo and drag it to the position as in Figure 13.4.

• Save the layout.

☞

• From the Insert menu, select the Text command or click the Text button 
in the Layout toolbar of the Layout editor. The Edit Text dialog box is
opened.

• Type the following in the text box:
Land use map,
Cochabamba, Bolivia

• Choose the Font Name: Arial and use Font Size: 28. 

• Select the Bold check box and click OK. The text appears in the layout.

☞



The position of the text and the size of the text can be changed. The text box size can
be changed by dragging one of its size handles. You can size the text in both directions
by dragging the corner size handles of the text box. To change the position of the text:

You can now add other texts: for the inset map of Bolivia, and to display the author
name.

Adding a north arrow

A north arrow points to the north of a map, based on the coordinate system or
georeference that is used by the maps in the map view. In the next step, a north arrow
is added to the layout.
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• Select the text box.

• Drag the box and place it at the top, right of the map view (see Figure 13.4). 

• Save the layout before proceeding.

☞

• Click the Text button in the Layout toolbar of the Layout editor. The
Edit Text dialog box is opened.

• Type the following in the text box:
Location map:

• Choose the Font Name: Times New Roman use Font Size: 12.

• Select the Bold check box and click OK. 

• In the Layout pane select the text box and position it at the top of the inset
map of Bolivia (see Figure 13.4).

• Repeat these steps to add the text Cochabamba to the inset map of Bolivia.
Select Font Color White, Font Name Arial and Font Size 8 and select
the Transparent check box.

• Insert also the word Bolivia and the Author Name and drag them to the
correct position.

☞

• Make sure the map view Landview is selected in the Layout pane.

• From the Insert menu, select North Arrow or click the North Arrow button
in the Layout toolbar. The Edit North Arrow dialog box is opened. 

• Select Arrow Type Wing.

• Select Font Name: Times New Roman, Font Size: 14 and click OK. The
north arrow is displayed in the layout.

• Position the arrow below the title of the map (see Figure 13.4).

• Resize the north arrow and make it smaller.

• Save the layout.

☞



Adding a scale bar

Map scale is a ratio indicating the relationship between the distance on the map and
the distance on the ground. In ILWIS, the map scale can be expressed in the follow-
ing ways:
- Graphically in the form of a scale bar
- As scale indication (e.g. 1:50000)

Adding scale text

The Scale Text option can be used to obtain a scale indication as text, e.g. below a
scale bar. For each map view in your layout, you can add a distinct scale indication. 

Creating a box

Finally, you will add a box to the map window that encloses the entire map. Boxes
can be used to emphasize certain annotation (e.g. text, legend, etc.), highlight certain
areas, emphasize features, etc. 
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• Make sure the map view Landview is selected in the Layout pane.

• From the Insert menu, select Scale Bar or click the Scale Bar button in
the Layout toolbar. The Edit Scale Bar dialog box is opened. 

• Select the Unit Indication check box.

• Select Font Name: Times New Roman, Font Size: 10 and click OK. The
scale bar is displayed in the map window.

• Position the scale box below the land use legend (see Figure 13.4).

• Save the layout.

• Make sure the map view Landview is selected in the Layout pane.

• From the Insert menu, select Scale Text or click the Scale Text button 
in the Layout toolbar. The Edit Scale Text dialog box appears. 

• Select Font Name: Times New Roman, Font Size: 12 and click OK. The
scale text is displayed in the layout.

• Position the scale box below the map view or below the scale bar and save
the layout.

☞

• From the Insert menu, select Box or click the Box button in the Layout
toolbar. The Edit Box dialog box is opened.

• Accept the defaults by clicking the OK button. A box is added to the map.

• Position the box close to the legend and resize it so that it encloses the whole
legend (see Figure 13.4).

☞

☞

➥



Editing map annotation

Existing annotation (map border, legend, picture, text, north arrow, scale bar, scale
text, box) can be edited by double-clicking an item. Grid lines or a graticule can not
be edited in the layout, but solely in a map window (see section 13.4).

Existing annotation can be removed from the layout using the mouse together with
the Del key of the keyboard or the Remove command on the Edit menu. You can
also click on the Remove button in the Standard toolbar. To remove an
annotation layer:

Summary: Layout and Annotation

A map has a primary content (the main theme of the map), a secondary content (base
map information, such as roads, contours, drainage), and a supportive content
(annotation like a legend, scale, north arrow, location map, etc.).

A Layout is required to print maps with annotation. The layout may contain: 
- Map views: one or more map views, each of which may include a raster map, and

multiple polygon, segment or point maps, annotation text layers, grid lines and/or a
graticule. For each map view, you need to specify the scale on which it should be
displayed and printed later on.

- Map border: border information for a map, optionally displaying: neat line gradua-
tion, grid and/or graticule ticks, grid, graticule and/or corner coordinates and a map
outline.

- Legends: a legend from the domain of any map in a map view and the representa-
tion used by that domain.

- An inset map, pictures or bitmaps: an inset map can be added as map view and pic-
tures or bitmaps can be pasted from Clipboard or inserted from file.
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• Repeat the steps to create a box for the entire layout. Make sure the box is
within the page margins.

• Save the layout.

➦

• Double-click the north arrow in the Layout pane. The Edit North Arrow
dialog box is opened. 

• Select the Half check box and click OK.

☞

• Select an Annotation layer and click on the Remove button in the
Standard toolbar.

☞



- Text: multiple lines of text (e.g. a title); select a font type and color for the created
text.

- North-arrow: showing the north orientation of a map from the georeference or
coordinate system that is used by a map view.

- Scale bar: adds a graphic scale (scale bar) to the layout. The type of scale bar, inter-
vals, font and colors are user-defined.

- Scale text: to obtain a scale indication as text in the layout. For each map view in
your layout, you can add a distinct scale indication.

- Box: can be placed around an annotation item.

The total composition of map views and annotation on a certain paper size is stored
as a layout and can be printed.
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13.6  Printing a map
ILWIS enables you to produce paper copies of a layout, which contain one or more
map views and annotation. Paper copies can be created in black and white or color,
depending on the printer connected to your computer. 

It is also possible to print only attribute data of a table. To this purpose, you can
select the Print command in the table window. In the Print Options dialog box, you
can select whether you want to see a header and leftmost column on all pages, and
you can set the font specifications.

Before you can print, you should make sure that the printer is correctly installed
under Windows. In this exercise, you will print the layout Landview that was
created in 13.5.

! If you change the paper size or orientation of the paper, you may have to
rearrange all items in the layout.

Summary: Printing maps

- ILWIS enables you to produce paper copies of a layout which contain map views
and annotation.

- Paper copies can be created in black and white or color, depending on the printer
you use.

- It is also possible to print only attribute data of a table. 
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• Open the layout Landview.

• From the File menu, select the Page Setup command. The Page Setup
dialog box is opened.

• Check whether the Paper Size A4 is selected.

• Still in the Page Setup dialog box, click the Printer button. The Page
Setup dialog box is opened. Make sure the correct printer is selected and
click OK.

• Click OK in the Page Setup dialog box.

• From the File menu, select the Print command. You can also use the Print
button in the Standard toolbar. The layout is now printed.

☞



13.7  Exporting maps to cartographic software
In order to be able to use data generated in ILWIS in specialized cartographic
software, you might need to export your maps to an interchangeable file format. In
that case, you need to export all required data layers and create a final map
composition in the cartographic software package you are using. 

Exporting your data is not needed if you use the cartographic software package ACE,
but it is recommended to transform your data to a georeference corners.

For raster maps, the easiest way is to convert to either Windows Bitmap format, or
TIFF format. Nearly all software packages dealing with maps and images are able to
read these file formats. These formats have the major disadvantage, however, that the
coordinate information is not converted. The imported files will thus lose their
coordinates. This will lead to problems when you want to combine a converted raster
map with vector information in the cartographic software. To make sure that the
exported file from ILWIS doesn’t lose its coordinates, the conversion to GeoTiff is
often used.

For vector data the most common file format is DXF, which is defined by AutoCad. 

For more information on how to export data, see the ILWIS Help topics Export and
How to export data.

In this exercise you will practice the conversion of raster and vector data. For raster
maps, conversion is fairly simple.

Exporting point maps and segment maps is also quite simple.
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• From the File menu of the Main window, select the Export command. The
Export dialog box is opened.

• Select the raster map Shadows from the list box.

• Select the Export Format: Tiff (Geotiff).TIF

• Type the Output Filename: Shadows and click OK. The raster map
Shadows is exported to TIF format.

☞

• From the File menu of the Main window, select the Export command. The
Export dialog box is opened.

• Select the point map Places from the list box.

• Select the Export Format: AutoCad.DXF, type the Output Filename:
Places and click OK. The point map Places is exported to DXF format.

• Repeat the operation for the segment map Drainage. Export it to
Drainage.DXF

☞



For polygon maps the situation is more complex, due to topological differences
between a GIS and a cartographic system. In ILWIS there is only one segment as
boundary line between two polygons, while in most cartographic packages it is
assumed that each polygon is enclosed by boundary lines, so there are in fact two
lines forming the boundary of two polygons. During the conversion of a polygon map
to DXF format, each polygon will be made so that it is enclosed by boundary lines.

If you want to show any ILWIS information e.g. as a picture, or even the data (tables)
in any other Windows application, you can always try to use the Copy in ILWIS and
Paste in the other package. In this way a map, table, etc. can be easily pasted into for
instance Microsoft Word or Power Point. To copy a whole window including
borders, Layer Management pane, etc., use Alt + PrintScrn in ILWIS.

! Use the Export to Bitmap option in the File menu of a Layout window to export
the layout to a Windows bitmap.

Summary: Exporting maps to cartographic software

- To use data generated in ILWIS in specialized cartographic software, you need to
export all required data layers to an interchangeable file format. 

- Raster maps can be converted to Windows bitmap or TIFF format or to GeoTiff
format when coordinate information should be preserved.

- Vector files are mostly converted to AutoCad DXF format.
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• From the File menu of the Main window, select the Export command. The
Export dialog box is opened.

• Select the polygon map Landuse from the list box.

• Select the Export Format: AutoCad.DXF, type the Output Filename:
Landuse and click OK. The polygon map Landuse is exported to DXF for-
mat.

☞



13.8  Creating demos with ILWIS
‘Professional’ users will use a specialized program to give demonstrations, but to
some extend, you can also do some automatic display in ILWIS. Two possibilities are
described:
- Double-click Action in a map window,
- Slide Show in a map window.

You can show ILWIS maps, a GIF image, a bitmap, play a sound or a video, etc.,
when a mapping unit in a domain class map or an element in a domain ID map is
double-clicked. In an attribute table linked to the map, there should be a column
called Action, which should have the string domain. In this Action column, you
specify a file name of a map or table and its extension (.MPR, .MPA, .MPS, .MPP,
.TBT), or a GIF image, picture, sound or video, that you want to see/hear when
double-clicking a mapping unit.

In Windows Explorer you should make sure that a default Open action is defined
for the file types which you would like to be opened when such a file type is double-
clicked. These are so-called registered file types. Native ILWIS extensions are already
associated with ILWIS during the setup of ILWIS. Most other file types will also
have a default program already, which will be used to open the files.

Make sure that:
- An attribute table is linked to the map.
- This attribute table has a column Action (column of domain string type).
- You have typed in this column file names inclusive of path and extension of the

map, table, GIF image, picture, sound or video, that should be opened when you
double-click a certain mapping unit or element.

- Windows knows which program should be used to open the map, table, sound
video, etc. This can be set in the File Types section in Windows Explorer. The
default Open action will be used to open the particular file type.

When you have set the Double-click Action to Execute Action in a map window
which displays a class or ID map, and double-click a unit in the map, then if an
attribute table is found with a column Action, in which a filename is found that has
a registered extension, then that file is opened (map or table is shown, audio or video
is played, etc.). 

Demo example: Display of field-photos

In this exercise, you will learn how you can make a demo, using a number of scanned
photographs from the Cochabamba area, and a point map showing the locations
where the photos were taken, represented as red dots. When you double-click on a red
dot, the appropriate photo is shown. The photos were obtained through the scanning
of snapshots and slides, using a simple scanner. These files are available in TIF
format (Photo1.tif to Photo9.tif). The locations where the photos were
approximately taken are stored in a point map. 
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If you want to show the photos in ILWIS map windows then the first thing that
should be done is to import the TIF Files. If you just leave the TIFF files as they are
and use them straight away in an attribute table probably a program like PhotoShop,
PaintShop, Windows Paint or even Internet Explorer may be used to open the
pictures.

As you can see the last photo (Photo9) is rotated. To rotate it into the normal
position you can use the operation Mirror Rotate.

The next step is to create a map view for each photo. The advantage of a map view is
that it will be displayed without showing first a Display Options - dialog box, since
the display options are already stored in the map view. Another advantage of using
map views is that you can give each map view a descriptive title, which will be
shown on the Title bar. You can also switch off Display Options - dialog boxes in
the Preferences (available via the File menu in the Main window).
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• From the File menu of the Main window, select the Import, General Raster
command. The Import dialog box is opened.

• Select the Import Format: Tagged Image File Format .TIF. The list
of TIF files appears in the list box.

• Select the File: Photo1.tif. The Output Filename is set to Photo1.

• Click OK. The file is converted.

• Repeat this procedure for the other photos or create a script.

• Display the various photos and close all map windows after you have finished.

☞

• Click the map Photo9 with the right mouse button and select the commands
Raster Operations and Mirror Rotate from the context-sensitive menu. The
Mirror Rotate dialog box is opened.

• Select the option Rotate 90 degrees clockwise. Type as Output Raster
Map name: Photo9r and click Show. The Display Options – Raster Map
dialog box is opened. 

• Click OK. The map is rotated and the result is displayed. Close the map win-
dow.

☞

• Open the map Photo1. Select from the File menu the Save View command.
The Save View As dialog box is opened. 

• Type the Map View Name: Photo1, and the Title: Country school in
the mountains.

• Close the map window.

• Repeat this for the other photos (Photo2 to Photo8, and Photo9r), and
create views with the same names. Type the descriptions as given in Table
13.5.

☞



Now the photos are finished. The next step is to adapt the file with the location of the
photos. This is a point map, with the name Photos.

The next step is to create a table that is linked to the point map Photos and which
contains a column Action, in which the names of the map views of the photos are
written.
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Table 13.5: Description of photos used in the demo.

View Title

Photo1 Country school in the mountains

Photo2 Cochabamba seen from the Colina de San Sebastian

Photo3 Indian village in the mountains

Photo4 Llamas grazing in the mountains

Photo5 Cochabamba by night

Photo6 Transporting Chicha and Coca

Photo7 Geologic fault

Photo8 Central park of Cochabamba

Photo9r Cochabamba beats Rio de Janeiro with 33cm

• Double-click point map Photos. The Display Options – Point Map dialog
box is opened. 

• Press the Symbol button. The Symbol dialog box is opened. 

• In the Symbol dialog box, select the Symbol Type: Simple, the Symbol:
Circle, the Size: 4, the Fill Color: Red, Line Width: 1 and the Color:
Red. 

• Click OK. You are back in the Display Options - dialog box.

• Select the Text check box and press the Font button. The Font dialog box
appears.

• Select the Font: Times New Roman, the Font style: Bold, and the Size:
12. 

• Click OK. You are back in the Display Options – Point Map dialog box.

• Select the Text Color: Red and click OK in the Display Options - dialog
box. The point map is displayed.

• Drag-and-drop raster map Shadows to the map window. The Display
Options dialog box is opened. Select the option Light and click OK. The
hillshading map is now also displayed in the map window.

• From the File menu select the Save View As command. The Save View As
dialog box is opened. 

• Type the Map View Name: Photos, the Title: Photos from the
Cochabamba area and click OK.

• Close the map window. 

☞



Now all input data is ready, so you can do the actual demo.

You can use this method also for segment, polygon or raster maps (domain type class
or ID) which have an attribute table where the files are listed that should be opened
with a double-click in the class or ID unit.

Creating a slide show

The second example of the preparation of a demo with ILWIS is the creation of a
slide show that can be used to display multi-temporal maps, in order to evaluate
changes through time. The operation Slide Show is meant for this purpose.

In a slide show, a map window shows multiple raster maps like a slide show. It is in
fact the same as repeatedly replacing the raster map in a map window, e.g. by
dragging the raster maps into the map window. The raster maps to be displayed must
all be stored in a map list. 
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• In the Operation-tree of the Main window, expand the Create option and
double-click New Table. The Create Table dialog box is opened. 

• Enter the Table Name: Photos, select the Domain Photos and click OK.
The table is opened.

• From the Columns menu in the table window, select the command Add
Column. The Add Column dialog box is opened.

• Type the Column Name: Action, select the Domain String and click
OK.

• Type the names of the map views in the column Action, including the
extension. So for the first record, with the domain item Photo1, you type
Photo1.mpv in the column Action. Make sure that the name of the last
field in column Action reads: Photo9r.mpv. The extension .mpv stands
for map view.

• Close the table window.

• Click the point map Photos with the right mouse button and select
Properties. The Properties sheet is opened. 

• Make sure that the Attribute Table check box is selected, select the table
Photos and click OK. 

☞

• Open map view Photos.

• From the Layers menu, select Double-Click Action and select the option:
Execute Action. 

• Double-click on any of the red dots, to see the map view of the photos. The
explanation of each photo is shown in the Title bar.

• Make sure to close all map windows when you have finished the exercise.

☞



A map list is a container object and stores the names of a set of raster maps, for
example of the multi-spectral bands of a satellite image that you want to classify. A
map list may also store the names of several raster maps of a time series, which you
can display as a slide show. 

In the slide show only one set of display options will be used. The defaults are based
on the first map in the map list. The parameters set for this map in the map list, also
define the display options for the other maps in the map list. So, a ‘constraint’ of
using a slide show is that all maps in the map list must use the same domain and the
same georeference.

The Slide Show operation is useful for multi-temporal monitoring, where data
regarding a site is collected on more than one occasion. It can, for example, be used
for observing a series of satellite images of the same area in time, derived products
such as NDVI, or classified maps, such as land use maps. In this way you get a clear
view of the general changes in time.

In this example, you will work with multi-temporal maps showing the growth of the
city of Manizales, located in central Colombia, with a set of 7 maps from 1851 till
1989. In order to show these maps as a slide show, you should first create a map list,
containing the names of these maps.

Now you can run the slide show.
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• From the File menu of the Main window, select the Create and the Map List
commands. The Create Map List dialog box is opened.

• Enter the Map List Name: Manizales.

• Enter the Description: Growth of the city of Manizales (Colombia).

• Select the raster maps M1851, M1930, M1949, M1960, M1970, M1977, and
M1989 (hold the Ctrl key down to select multiple maps at a time), press the
> button and click OK. 

☞

• Double-click map list Manizales in the Catalog.

• In the map list, click the Open As Slide Show button . The Display
Options - Raster Map dialog box is opened, with the display options for the
first map (M1851). 

• Accept the defaults and click OK. The Display Options - Map List dialog
box is opened. In this dialog box you can change the Refresh Rate, indicat-
ing how many times per minute the display will be changed. 

• Change the Refresh Rate to 30 and click OK.

• Maximize the window, open the Options menu and select the option No
Zoom. 

☞



Now the maps are displayed in the map window one by one, so that you can evaluate
the changes quite easily. You can change the refresh rate, to make the display slower
or more rapid.

Summary: Creating demos in ILWIS

- You can show ILWIS maps, a GIF image, a bitmap, play a sound or a video, etc.,
when a mapping unit is double-clicked in a map which has a domain class or a
domain ID. 

- Another way of demonstration in ILWIS is the creation of a slide show that can be
used to display multi-temporal maps in order to evaluate changes through time. The
Slide Show operation is meant for this purpose.
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• When you have finished watching the slide show, close the map window.☞


