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Introduction In this tour guide, you can learn how to:

• set Preferences

• display an image

• query for pixel information

• arrange layers

• adjust image contrast

• link Viewers

• use the Area of Interest (AOI) function 

• use the Raster menu functions (Raster Attribute Editor, 
Measurement tools, and so on)

• use the geospatial light table

Approximate completion time for this tour guide is 45 minutes.

Display 
Preferences

ERDAS IMAGINE allows you to set up default band-to-color gun 
assignments for Landsat MSS, Landsat TM, SPOT, and AVHRR data 
in the Preference Editor. 

Check Band-to-Color 
Gun Assignments

ERDAS IMAGINE should be running and a Viewer should be open.

1. Click the word Session in the upper left corner of the ERDAS IMAGINE 
menu bar.

2. From the Session menu, click Preferences.

The Preference Editor opens.

Viewer & Geospatial Light Table

ER

Leave the Display
Preferences for the
moment being as
they are

Displayp y
Preferences

IIntroduction

Introduction
Exercise_1:
"Getting to know
the "ERDAS
Imagine Interface"

damen
Sticky Note
MigrationConfirmed set by damen

damen
Sticky Note
MigrationConfirmed set by damen

damen
Cross-Out

damen
Replacement Text
Use the ETM image of 1999





damen
Callout
Use the Landsat ETM image of 1999
of Dedoplistskar
File: Dedo_ETM_20Aug99_ms

damen
Sticky Note
Marked set by damen



2 Viewer & Geospatial Light Table

3. Drag the scroll bar on the right side of the dialog down to see all of the 
User Interface & Session preferences (User Interface & Session is 
the default under Category). 

You may change these or any other preferences at any time by 
selecting the preference category (click the list below Category) and 
then editing the text in the text entry fields. 

4. Under the User Interface & Session category in the Preference Editor, 
locate the preferences for the 3-Band Image Red Channel default, 3-
Band Image Green Channel default, 3-Band Image BlueChannel 
default, 4-Band Image Red Channel default, 4-Band Image Green 
Channel default, 4-Band Image Blue Channel Default, 5-Band 
Image Red Channel default, 5-Band Image Green Channel default, 
5-Band Image Blue Channel Default, 6-or-greater-Band Image Red 
Channel default, 6-or-greater-Band Image Green Channel default, 
and 6-or-greater-Band Image Blue Channel Defaults.

The number that is entered for these defaults shows the band that is 
used for the Red, Green, and Blue color guns in your display. You may 
change these defaults. These are the band assignments that display in 
the Layers to Colors section of the Select Layer To Add dialog when it 
opens. These assignments can also be changed in the Select Layer To 
Add dialog for specific files.

Check Viewer 
Preferences

1. With the Preference Editor still open, click the Category list and select 
Viewer. 

The Viewer preferences display.

Click here
to see on-line
help for this
dialog

Click here 
to select the
preference

Click here
to see on-line
help for this
category

categories 
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2. Drag the scroll bar on the right of the dialog down to see all of the 
Viewer preferences. 

These preferences control the way the Viewer automatically displays 
and responds each time it opens.

Check Preference Editor 
Help

1. Click Help in the lower right corner of the dialog. 

The On-Line Help for the Preference Editor opens.

2. When you are through studying the Preference Editor help file, select 
File -> Exit from the On-Line Help file menu bar. 

The On-Line Help file closes.
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View Category Help

1. Click the Category Help button on the Preference Editor.

The On-Line Help for this category, Viewer, opens.

2. When you are through studying the Viewer preferences help file, select 
File -> Exit from the On-line Help file menu bar. 

3. Click the Close button on the Preference Editor. 

NOTE: If you have changed any preferences, you can save them at this 
time by clicking the User Save or Global Save buttons on the 
Preference Editor dialog.
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Display an Image Next, you display a Landsat Thematic Mapper (TM) image of 
Gainesville, Georgia in a Viewer. 

Since the data files in the <ERDAS_Data_Home>/examples directory 
are read-only, you may want to copy them to a new directory and 
change the file permissions. Remember, <ERDAS_Data_Home> 
represents the name of the directory where sample data is installed.

1. In the Viewer menu bar, select File -> Open -> Raster Layer.

You can also open this dialog using either of these two methods:

— use the keyboard shortcut, Ctrl-r

— click this icon  in the Viewer toolbar.

The Select Layer To Add dialog opens.

2. In the Select Layer To Add dialog, click the Recent button.

A dialog with a listing of the most recent files you have opened displays. 
You can individually select these files and then click OK to display them 
quickly in the Select Layer To Add dialog.

3. Click Cancel in the List of Recent Filenames dialog.

4. In the Select Layer To Add dialog, click the Goto button.

A dialog with a listing of the most recent directories you have opened 
displays. You can individually select these directories, or enter the 
name of a new directory, and then click OK to display that directory 
quickly in the Select Layer To Add dialog.

A preview of the 
image displays 
here 

Click this 

change file types 
dropdown list to 

Click here 
to select file 

file name 
part

Display an Image

Here we display the
available SPOT-5
image of the coast
of the Kaspian sea
coast:
File: Coast_SPOT5

Go to the folder
with the file name
of the SPOT
satellite image

Click hereClick here
to select file 
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5. Click Cancel in the Select a Directory dialog.

NOTE: The Recent and Goto buttons in the Select Layer To Add dialog 
are helpful for quickly locating and displaying a file or directory you work 
with often.

6. In the file name part of the Select Layer To Add dialog, click the file 
lanier.img. 

This is a Landsat TM image of the Gainesville, Georgia area, including 
Lake Lanier. Information about this file is reported in the bottom, left 
corner of the Select Layer To Add dialog. This true color image has 
seven bands, 512 columns, and 512 rows.

7. Click the Raster Options tab at the top of the Select Layer To Add 
dialog. 

The Raster Options display. 

8. Under Layers to Colors, display band 4 in the Red color gun, band 5 
in the Green color gun, and band 3 in the Blue color gun.

File Name Part

The framepart under Filename is called a file name part. A file 
name part is a tool used to select specific files for use in an ERDAS 
IMAGINE function. A file name part consists of:

• a text field—for entering the file name by typing it in, or clicking 
on, the file from the scroll list.

• a scrolling list—shows the name of all files with the default 
extension in the selected directory. Files can be selected by 

Click this file tab 
to display the 
raster options 

Click here to 

image in the 
display the 

Viewer 

Change the layer 
to color band 
assignment here 

lanier.img.
Select the
filename of the
SPOT satellite
image

Change the layer Change the la
to color band

gg
to color band 
assignment here
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four image bands of
the SPOT
Try: R G B 1 2 3

This is a Landsat TM image of the Gainesville, Georgia area, includingg g
Lake Lanier. Information about this file is reported in the bottom, left p
corner of the Select Layer To Add dialog. This true color image has y g
seven bands, 512 columns, and 512 rows.

Under Layers to Colors, display band 4 in the Red color gun, band 5y p y
in the Green color gun, and band 3 in the Blue color gun.

damen
Text Box
Select the filename:
Dedo_ETM_20aug99_ms

damen
Text Box
Try also other band combinations

damen
Cross-Out



Viewer & Geospatial Light Table 7

Display Options

1. Note the display options in the Select Layer To Add dialog.
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Display Options Defaults

The default settings of the Raster Options tab are briefly described 
below: 

• Orient Image to Map System—This checkbox is enabled if 
calibration is saved to the image file. If there is no calibration, this 
option is disabled. When enabled, the image displays using 
calibration. Otherwise, the calibration is ignored.

• Clear Display—When this checkbox is enabled, and a new 
image is loaded, the image currently displayed in the Viewer is 
removed. Disable this checkbox to overlay images.

• Fit to Frame—If this checkbox is enabled, the image is magnified 
or reduced to fit the Viewer window at its current size.

• Data Scaling—The Viewer performs a two standard deviation 
stretch by default. Click this checkbox to select an alternate data 
range to stretch.

If you want to save the contrast stretched values with the image, 
you can use the Radiometric Enhance -> LUT Stretch option of 
Image Interpreter. 

• Zoom by—If Fit to Frame is disabled, then you can enter the 
zoom ratio for the data in this data field.

• Set View Extent—Allows you to specify the upper left and lower 
right coordinates of the portion of the image to display.

The coordinates in this dialog set the area of the image to display 
in the Viewer. This is useful if you have an image that is larger 
than the Viewer window, or if you want only a specific portion of a 
large image to display in the Viewer. You can also select View -> 
Scale -> Extent from the Viewer menu bar. 

Display Options Defaults

Read the text
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2. Click OK in the Select Layer To Add dialog to display the file.

The file lanier.img displays in the Viewer. The name of the file and the 
layers selected are written in the Viewer title bar.

Utility Menu 
Options

The Utility menu on the Viewer enables you to access four separate 
groups of functions:

• inquiry functions 

• measurement tool

Display Options Defaults, Continued

• Background Transparent—Click to make the background of 
grayscale, pseudocolor, and true color areas transparent—the 
layer underneath shows through. Background areas are 
automatically transparent in thematic layers.

• Using—Resampling is appropriate if the image is magnified (a 
magnification factor greater than one). Use one of the following 
resampling methods: Nearest Neighbor, Bilinear Interpolation, 

Click here to minimize the window

The title bar shows
the Viewer number
and name of image
displayed 

Drag on any
of the corners
to resize the Viewer

In the title bar,

move the Viewer
hold and drag to

Use the scroll bars
to roam in an image

Single-line help and coordinates 
display in this Status Bar

dlaanier.img e l

SPOT image

damen
Text Box
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• layer viewing

• information

Each function group is separated by a line in the dropdown menu.

Use Inquiry Functions You can query a displayed image for information about each pixel using 
the inquiry functions.

The file lanier.img must be displayed in a Viewer.

1. Select Utility -> Inquire Cursor from the Viewer menu bar. 

A white crosshair displays in the Viewer and the Inquire Cursor dialog 
opens.

You can move the Inquire Cursor in the Viewer using any of these 
methods:

• Drag the white crosshair over the image.

• Enter new coordinates into the CellArray™ of the Inquire Cursor 
dialog. The Inquire Cursor moves when you move the mouse cursor 
back into the Viewer.

• Click the black arrows at the bottom of the Inquire Cursor dialog.

As the crosshair is moved, the information in the Inquire Cursor dialog 
automatically updates. 

Drag the crosshair 
over the image in the Viewer 
or click here to move it 

Drag the scroll bars 

Map projection/spheroid 
listed here 

Drag any corner to enlarge 
the CellArray for more information for more details

Pixel information
reported in this
CellArray

Click arrows to move
 

the Inquire cursor

Click the circle to move the Inquire 
cursor to the center of the image 

SPOT image
anier.imglae  l
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2. The CellArray in the Inquire Cursor dialog reports a variety of pixel 
information. Drag on the horizontal scroll bar (or enlarge the Inquire 
Cursor dialog by dragging any corner) to show all of the pixel 
information available in the CellArray. 

Change Inquire Cursor 
Style

You can change the color and shape of the Inquire Cursor to make it 
more visible in the Viewer. 

1. To change the color of the Inquire Cursor, select Utility -> Inquire 
Color from the Viewer menu bar.

The Inquire Color dialog opens. 

2. Select a new color for the Inquire Cursor by holding on the Inquire 
Color dropdown list and dragging to select the desired color. 

3. Click OK in the Inquire Color dialog.

The Inquire Cursor changes color.

4. To change the shape of the Inquire Cursor, select Utility -> Inquire 
Shape from the Viewer menu bar.

The Inquire Shape dialog opens.

5. Click circle.cursor in the scroll list that displays, then click Apply. 

The Inquire Cursor becomes a circle.

Hold on the dropdown 
list to select a new 
color 

Click to make the 
Inquire Cursor an 
icon or a cursor 

Click here to 
apply the new shape
to the Inquire Cursor

Click to select
a new shape

Change Inquire Cursor 
Style

You can do this
at a later moment
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6. In the Inquire Shape dialog, click the Use Cursor button, then Apply to 
return the Inquire Cursor to the original crosshair shape. 

7. Click Close in the Inquire Shape and the Inquire Cursor dialogs.

The Inquire Cursor is cleared from the Viewer.

Take Measurements The Measurement tool enables you to measure points, lines, polygons, 
rectangles and ellipses in the displayed layer. Both distance and area 
are reported in the units you select.

1. Click the Measurement icon  in the Viewer toolbar or select Utility 
-> Measure from the Viewer menu bar. 

The Measurement Tool viewer opens.

2. Click the Measure Positions icon  in the Measurement toolbar. This 
tool gives the individual point coordinates (x, y) in the image.

3. Move the cursor into the Viewer and click anywhere. 

In the Measurement Tool viewer, the location of the point displays in the 
type of units in which the file is saved. You may select different display 
units from the dropdown lists in the top toolbar.

4. Next, click the Polyline icon  in the Measurement Tool viewer 
toolbar.

5. Move the cursor into the Viewer and click once at the beginning of a line 
feature then drag the mouse to extend the line along the feature. Click 
to add a vertex at each point. Middle-click (or double-click, depending 
on how your Preferences are set) to end the measurement. 

The length displays in the Measurement Tool CellArray. 

Click to print 

Click to 
locate point 
coordinates 

Take Measurements

Compare the
measurements
with the scale
of the map
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6. Click the Print icon  to print and a Print dialog opens, which allows 
you to enter or select the printer to be used. 

7. Select the Printer and click Print (or OK) in the Print dialog. If you do 
not wish to print, click Cancel.

8. Experiment with the other measurement tools if you like, and when you 
are done, click the Close button in the top toolbar. 

You are asked if you want to save the measurements. Save them if you 

like. You can click the Save icon  at any time to save your 
measurements.

Click the Help button to view the On-Line Help for the 
measurement tools.

View Menu 
Options

Arrange Layers ERDAS IMAGINE should be running, and lanier.img should be 
displayed in a Viewer.

1. In the Viewer toolbar, click the Open icon  to open another layer on 
top of lanier.img. 

The Select Layer To Add dialog opens.

The Measurement Tool

The Measurement Tool can create a new annotation layer on top of 
your image. Simply click the Annotation tool and a new layer is 
automatically created. While this tool is enabled, the measurement 
features (points, polylines, polygons, rectangles, ellipses, etc.) are 
added to the annotation layer as well as a text box containing the 
measured values. Click the tool again to turn this feature off.

The annotation layer may be saved and used with other images with 
the same geographic area.

 lanier.img 

SPOT Image

lanier.img. 

Click the Print icon to print and a Print dialog opens, which allows 
you to enter or select the printer to be used.

7. Select the Printer and click Print (or OK) in the Print dialog. If you do
not wish to print, click Cancel.
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2. In the Select Layer To Add dialog under File name, click lnsoils.img. 
This is a thematic soils file of the Gainesville, Georgia area. 

3. Click the Raster Options tab at the top of the Select Layer To Add 
dialog.

4. Check to be sure that the Clear Display checkbox is disabled (not 
selected), so that lanier.img is not cleared from the Viewer when 
lnsoils.img displays.

5. Click OK in the Select Layer To Add dialog to display the file.

Now, both lanier.img and lnsoils.img are displayed in the same 
Viewer, with lnsoils.img on top. 

6. To bring lanier.img to the top of the Viewer, select View -> Arrange 
Layers from the Viewer menu bar.

The Arrange Layers dialog opens.

7. In the Arrange Layers dialog, drag the lanier.img box above the 
lnsoils.img box, as illustrated above.

When you release the mouse button, the layers are rearranged in the 
Arrange Layers dialog so that the lanier.img box is first.

8. Click Apply in the Arrange Layers dialog to redisplay the layers in their 
new order in the Viewer. 

The layers are now reversed. 

9. Click Close in the Arrange Layers dialog.

Click and drag 
this box to the top
to change the
order of the 
displayed layers

Click here to
redisplay layers
in the new order

lnsoils.

MODIS Reflection image
of the Kaspian sea

.img.y g
This is a thematic soils file of the Gainesville, Georgia area. 

lanier.img lnsoils.img 
lnsoils.img 

gMODIS image on
top of the SPOT
image lanier.img 

lanier.img 
lnsoils.img 

Drag the SPOT
image on top of
the MODIS image
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Zoom In this section, you zoom in by a factor of 2 and create a magnifier 
window. Once the image enlarges, you can roam through it.

lanier.img should be displayed on top of lnsoils.img in a Viewer at a 
magnification of 1 (this is the case if you have been following through 
this tour guide from the beginning).

1. Select View -> Zoom -> In by 2 from the Viewer menu bar.

The images are redisplayed at a magnification factor of 2.

The Zoom options are also available from:

— the Quick View menu (right-hold on the Viewer image) under 
Zoom -> Zoom In by 2

— the Viewer toolbar by clicking this icon  .

2. Move the scroll bars on the bottom and side of the Viewer window to 
view other parts of the image. 

To move by small increments, you can click the small triangles at either 
end of the scroll bars. To move by larger increments, drag the scroll 
bars. 

You can also enlarge the Viewer window by dragging any corner.

3. Select View -> Create Magnifier from the Viewer menu bar.

A white cursor box opens in the center of the image. This area displays 
in a small magnifier window that opens over the top corner of the 
Viewer.

if lnsoils.img lanier.img 

SPOT image on
top of MODIS
image

damen
Text Box
ETM image of 1999 on top of ETM 2007
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4. With your pointer inside the white cursor box, hold and drag the box 
around the image.

The data in the magnifier window changes as the cursor box is moved 
over the image. This technique is called chip extraction, which is used 
in the Rectification tools to help you precisely identify ground control 
points (GCPs).

5. In the Viewer menu bar, select File -> Close Other Viewers to close 
the magnifier window.

Image in this new Viewer
is a magnified view of
the image area under
this cursor box
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Other methods of zooming in and out of imagery are Animated Zoom, 
Box Zoom, and Real-time Zoom. 

Animated Zoom Animated Zoom enables you to zoom in and out of the Viewer’s image 
in a series of steps that are similar to animation. The image is 
resampled after it is magnified or reduced.

Display lanier.img in the Viewer. 

1. Select Session -> Preferences.

2. In the Preference Editor dialog, select Viewer from the Category list. 

3. Click the checkbox for Enable Animated Zoom.

4. Click User Save then Close in dialog, and go back to the Viewer.

5. Click the Zoom In By Two icon  .

The Viewer zooms into the image in a simulated animation by a factor 
of 2. The Viewer center is maintained.

6. Click the Zoom Out By Two icon  . 

Magnifying Areas

There are four ways to change the size of the area magnified:

• With the cursor on any corner (or side) of the cursor box, drag the 
box until it is the desired size.

• Place the cursor on the lower right corner of the magnifier window 
and drag the magnifier window until it is the desired size.

• Press the space bar to enter precise positioning coordinates in 
the inquire box dialog.

• Use the Quick View menu (from the right mouse button) or the 
View menu (from the Viewer menu bar) to zoom in either Viewer.

As you try these methods, you notice that each change in size is 
reflected in the other window. As the cursor box is adjusted, the 
magnification in the magnifier window is adjusted to accommodate 
the new area. Likewise, as the magnifier window is adjusted, the 
cursor box changes to reflect the new size and proportion.

Magnifying Areas

Read the text

lanier.img 

SPOT image

damen
Text Box
ETM of 1999
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The Viewer zooms out of the image in a simulated animation by a factor 
of 2. The Viewer center is maintained. 

7. Click either the Interactive Zoom In  or the Interactive Zoom Out 

icon  .

8. Click a location on the image. 

The Viewer recenters the image to that location and zooms in or out in 
a simulated animation by a factor of 2.

Animated zoom also works with View -> Zoom -> In by X and Out 
by X.

Box Zoom Box Zoom is used to select a boxed area in the image. When zooming 
in or out by using the zoom recentering icons, the boxed image enlarges 
or reduces within the Viewer.

Display lanier.img in the Viewer. 

1. Select Session ->Preferences.

2. In the Preference Editor dialog, select Viewer from the Category list. 

3. Click to select Enable Box Zoom.

4. Click User Save then Close in dialog, and go back to the Viewer.

5. Click the Interactive Zoom In icon. 

6. Click and drag a box in the image. 

The selected area of the image is magnified to fit the Viewer. 

7. Select the Interactive Zoom Out icon. 

8. Click and drag a box in the image. 

The area displayed in the Viewer is reduced to fit in the box. Space 
surrounding the reduced image is populated with available imagery.

Real-time Zoom When you select either of the Interactive Zoom tools, you can to zoom 
into and out of images in real time by holding the middle mouse button 
and moving the mouse upward and downward over the image.

NOTE: You can also hold down the Control key and press on the left 
mouse button to zoom in real time.

lanier.img 

SPOT image
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Display lanier.img in the Viewer. There is no need to set up a 
preference for this feature.

1. Select either of the Interactive Zoom icons. 

2. Position the cursor in the Viewer, and hold the middle mouse button. 

3. Move the mouse forward to zoom in on the image. 

The image magnifies at a constant rate, depending on how far forward 
you move the mouse.

4. Hold the middle mouse button and move the mouse backward. 

The image reduces at a constant rate, depending on how far downward 
on the image you move the mouse.

Display Two Images Two or more Viewers can be geographically or spectrally linked so that 
when you roam in one image, that area is simultaneously displayed in 
the linked Viewer(s). 

The file lanier.img should be displayed on top of lnsoils.img in a 
Viewer window, at a magnification of 2.

1. Drag on a lower corner of the Viewer so that it occupies the entire left 
half of the screen.

2. In the Viewer menu bar, select View -> Split -> Split Horizontal.

The Viewer is divided in half, horizontally, to form two Viewers.

3. In the toolbar of the new Viewer, click the Open icon  . 

The Select Layer To Add dialog opens.

4. In the Select Layer To Add dialog under File name, click the file 
lnsoils.img.

5. Click the Raster Options tab at the top of the dialog.

Types of Linking

• Geographically linked—the same image area displays in all 
linked Viewers.

• Spectrally linked—enhancements made to an image are also 
made in other Viewers if that same image, or portions of it, are 

lnsoils.img slanier.img SPOT on top of
MODIS

lnsoils.img. MODIS image

lanier.img 

SPOT5
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6. Confirm that Zoom by is set to 1.00.

7. Click OK in the Select Layer To Add dialog.

The file lnsoils.img displays in the second Viewer.

Link Viewers

1. In the first Viewer, select View -> Link/Unlink Viewers -> 
Geographical.

The Link/Unlink Instructions display.

2. Move your pointer to the second Viewer.

The pointer becomes a Link symbol  .

3. Move the pointer to the first Viewer. 

The No Link symbol  displays as the cursor in the first Viewer. 
Clicking in this Viewer discontinues the link operation.

4. To link the Viewers, click anywhere in the second Viewer.

The two Viewers are now linked. A white cursor box opens over the 
image in the second Viewer, indicating the image area displayed in the 
first Viewer.

You can move and resize this cursor box as desired, and the image 
area in the first Viewer reflects each change. This is similar to the 
magnification box you used earlier.

Compare Images

1. Drag the cursor box in the second Viewer to a new location. The image 
area selected in the second Viewer displays in the first Viewer.

2. Drag the scroll bars in the first Viewer to roam in the image. 

The white cursor box in the second Viewer moves as the image area in 
the first Viewer changes.

You could also use the Roam icon  in the Viewer toolbar to roam 
over the image. Just move the hand across the Viewer image to 
change the view.
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Unlink Viewers

1. In either Viewer, select View -> Link/Unlink Viewers -> Geographical 
to unlink the Viewers.

The Link/Unlink Instructions display.

2. Move the pointer to the other Viewer.

The unlink cursor  displays.

3. Click anywhere inside the Viewer to unlink the Viewers.

4. In the menu bar of the second Viewer, select File -> Close. 

The second Viewer closes.

5. In the first Viewer, select File -> Clear to clear the Viewer.

Raster Menu 
Options

Create an AOI Layer These options allow you to define an AOI in the image, excluding other 
parts of the image. Specific processes can be applied to this AOI only, 
which can save considerable time and disk space. The option to use a 
specified AOI for processing is available from many dialogs throughout 
ERDAS IMAGINE. 

This exercise tells you how to create an AOI layer that can be saved as 
a file and recalled for later use. 

NOTE: Each Viewer can display only one AOI layer at a time.

Display lanier.img in a Viewer. You must have an image displayed in 
the Viewer to create an AOI layer.

1. Select File -> New -> AOI Layer from the Viewer menu bar. 

ERDAS IMAGINE creates an AOI layer. 

2. Select View -> Arrange Layers from the Viewer menu bar to verify that 
the AOI layer has been created. 

The Arrange Layers dialog opens, and should look similar to the 
following example: 

lanier.img SPOT image

damen
Text Box
ETM of 1999
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3. After verifying the creation of the AOI layer, click Close in the Arrange 
Layers dialog.

Later, you are asked to name the layer and save it to a file.

Open AOI Tools 

1. Select AOI -> Tools from the Viewer menu bar (or click the Tools icon 
on the toolbar). 

The AOI tool palette displays.

2. Click the Rectangle icon in the AOI tool palette  .

3. Move the cursor into the Viewer window. Drag and then release to draw 
a rectangle over the AOI. Include a portion of the water when 
designating the AOI.

A rectangular AOI displays in the Viewer. 

This signifies that an 
AOI layer was created 

Click here
when you have
verified the
creation of the
AOI layer 

Click to draw
a rectangular AOI Click to plant

a seed to grow a
regional AOI

Click to select
an AOI
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Select Styles

1. Select AOI -> Styles from the Viewer menu bar. 

The AOI Styles dialog opens.

Rectangular AOI 

Selecting AOIs

Following are some tips regarding the selection of the AOI:

• You can move the AOI by dragging the AOI to a new location. 

• You can resize the AOI by dragging any of the handles at the 
corners and sides of the bounding box, or by pressing the space 
bar to enter precise coordinates.

•  The x in the center of the bounding box marks the center 
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This dialog enables you to change the style of the AOI display. 

2. Experiment in the AOI Styles dialog with the line widths and colors to 
find a style that looks best on the displayed image.

3. When you are finished, click Close in the AOI Styles dialog.

Set Seed Properties

1. Next, select AOI -> Seed Properties from the Viewer menu bar.

The Region Growing Properties dialog opens.

This dialog enables you to define the region that grows from the seed.

2. In the Region Growing Properties dialog, change the Spectral 
Euclidean Distance to 5.00.

3. Click Set Constraint AOI in the Region Growing Properties dialog.

The Choose AOI dialog opens.

4. In the Choose AOI dialog, select Viewer under AOI Source and then 
click OK.

Click to apply the new 
style to the AOI 

Click to see 
On-Line Help 
for this dialog 

Click to fill the AOI 
polygon with a color 

Right-hold to 
select a new color 

 

Click to select 
an AOI to constrain 
the region growing 

Adjust the Spectral 
Euclidean Distance 
here 

Set Seed Properties

Do this at a later
occassion
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5. Click the Region Grow AOI icon  in the AOI tool palette. 

Click this tool to plant seeds, or points in the Viewer, from which to grow 
a regional AOI. The region grows in the Viewer as an AOI that can be 
selected.

6. Move the cursor into the Viewer window and click the water inside the 
rectangular AOI to indicate where you want the region growing to take 
place.

A status meter displays in the status bar of the Viewer. You may click 
Cancel to terminate the region grow process. The meter dismisses 
when the region growing process is complete. The area you selected in 
the Viewer is surrounded by a second bounding box and chaser lights.

7. Click Close in the Region Growing Properties dialog.

Save AOI

1. Select File -> Save -> AOI Layer As from the Viewer menu bar. 

The Save AOI As dialog opens. This dialog allows you to save the 
selected AOIs as a layer (.aoi extension) that can be used again for 
other functions. 

2. Enter a name for the AOI layer under Save AOI as (the .aoi extension 
is added automatically). Pay special attention to the directory where the 
file is saved, so you can find the layer later. 

If you wanted to save specific AOIs only, you could turn on the 
Selected Only checkbox in the Save AOI As dialog, and only 
selected AOIs would be saved to a file.

3. Click OK in the Save AOI As dialog. 

This layer can now be used in any dialog where a function can be 
applied to a specific AOI layer. You can also edit this layer at any time, 
adding or deleting areas. 

Arrange Layers

1. Select View -> Arrange Layers from the Viewer menu bar. 

The Arrange Layers dialog opens.

2. In the Arrange Layers dialog, right-hold over the AOI Layer and select 
Delete Layer from the AOI Options menu.
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3. Click Apply and then Close in the Arrange Layers dialog.

The file lanier.img is redisplayed in the Viewer without the AOI layer.

Adjust Image Contrast When images are displayed in ERDAS IMAGINE, a linear contrast 
stretch is applied to the data file values, but you can further enhance the 
image using a variety of techniques.

The file lanier.img should be displayed in a Viewer.

1. In the Viewer menu bar, select Raster -> Contrast -> 
Brightness/Contrast.

The Contrast Tool dialog opens.

2. In the Contrast Tool dialog, change the numbers and/or use the slider 
bars to adjust the image brightness and contrast.

3. Click Apply.

The image in the Viewer is redisplayed with new brightness values.

4. Click Reset and Apply in the Contrast Tool dialog to undo any changes 
made to the Viewer image.

5. Click Close in the Contrast Tool dialog.

Use Piecewise Linear 
Stretches

1. In the Viewer menu bar, select Raster -> Contrast -> Piecewise 
Contrast.

The Contrast Tool dialog for piecewise contrast opens.

Adjust 
brightness 
here 

Adjust 
contrast 
here 

Click here to 
reset to original 
contrast 

Click here or here 
to apply changes 

islanier.img 

SPOT
lanier.img 

SPOT
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2. With your pointer over the image in the Viewer, right-hold Quick View 
-> Inquire Cursor.

The Inquire Cursor dialog opens and an Inquire Cursor is placed in the 
Viewer.

Adjust contrast 
and brightness 
here 

Specify range 
of lookup table 
to modify here 

Set lookup 
table ranges 
here 

Select color 
gun to affect 

Click here to reset 
to the original 
lookup table 

contrast 

The Contrast Tool

This tool enables you to enhance a particular portion of an image by 
dividing the lookup table into three sections: low, middle, and high. 
You can enhance the contrast or brightness of any section using a 
single color gun at a time. This technique is very useful for enhancing 
image areas in shadow, or other areas of low contrast. 

The brightness value for each range represents the midpoint of the 
total range of brightness values occupied by that range.

The contrast value for each range represents the percent of the 
available output range that particular range occupies.

As one slider bar is moved, the other is automatically adjusted, so 

The Contrast Tool

Read the text
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3. In the Viewer, drag the intersection of the Inquire Cursor to the lake. 
Move the Inquire Cursor over the water while keeping an eye on the 
lookup table values in the blue color gun, as reported in the Inquire 
Cursor dialog. 

This gives you an idea of the range of data file values in the water. You 
can stretch this range to bring out more detail in the water. 

4. In the Contrast Tool dialog, click Blue under Select Color.

5. Under Range Specifications, set the Low range From 34 To 55 and 
press Enter on your keyboard.

6. Drag the Brightness slider bar (the top slider bar) to 50.

7. Click Apply in the Contrast Tool dialog. 

The water now has more contrast and shows more detail.

If your image is at a magnification of 1, this new detail may be difficult 
to see. You can zoom in to a magnification of 2 using the Quick View 
menu in the Viewer.

8. In the Contrast Tool dialog, click Reset and then Apply to return the 
image to the original lookup table values.

9. Click Close in the Contrast Tool dialog.

10. Click Close in the Inquire Cursor dialog.

Manipulate Histogram

1. In the Viewer menu bar, select Raster -> Contrast -> Breakpoints.

The Breakpoint Editor opens. 

From 34 To 55 

50.

Values might be
different for
SPOT image

damen
Text Box
Values might be different 
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2. Click the dropdown list at the top of the Breakpoint Editor and select 
Red.

Each of the three histogram graphics in the Breakpoint Editor can be 
expanded up to full size by selecting the appropriate histogram from the 
dropdown list at the top of the Break Point Editor. The parts of the 
histogram graphic are described in the following illustration.

Indicate which 
histograms 
to view 

Click to 
apply changes 
made to all 
histograms 

Allows you to set 
histogram display 
options 

Click to 
apply changes 
to the red 
histogram only 

Enlarge the

by dragging on 
any corner 

histograms 
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3. Click the dropdown list at the top of the Breakpoint Editor and select 
RGB.

All three histograms redisplay in the Breakpoint Editor.

4. Experiment by dragging the breakpoints of the lookup table graphs in 
the different color guns (Red, Green, and Blue).

5. Click Apply All in the Breakpoint Editor to view the results of your 
changes in the image.

6. To undo the edits you just made, select Raster -> Undo from the 
Viewer menu bar.

Adjust Shift/Bias

1. In the Breakpoint Editor, click the Shift/Bias icon  on the toolbar.

The Shift/Bias Adjustment dialog opens.

The Y axis 
represents both 
the frequencies 
of the histogram 
and the range 
of output values 
for the lookup table 

The X axis The histogram of the 
input values (white) 
does not change 

The histogram of 

represented 
frequency 
The highest 

The lookup table 

you manipulate the 
(red) changes as 
the output values 

lookup table graph 

range of values 

range is 0 to 255)

represents the 

(for 8-bit data, the 

breakpoints 
graph with 

(small squares) 

Histogram Edit Tools 
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The lookup table graph and the output histogram are updated in the 
Histogram Tool dialog as you manipulate the information in the 
Shift/Bias Adjustment dialog.

2. In the Shift/Bias Adjustment dialog, drag the Shift slider bar to the right.

Notice that the value in the number field to the left increases as you 
move the slider bar. This is the number of pixels that the lookup table 
graph is moved.

3. In the Shift/Bias Adjustment dialog, double-click the number in the Shift 
number field and change the number field to 20. Press Enter on your 
keyboard.

4. In the Breakpoint Editor, click Apply All.

The image is redisplayed using the new lookup table. It is very dark.

5. In the Shift/Bias Adjustment dialog, return the Shift value to 0.

6. In the Breakpoint Editor, click Apply All to return the image to its 
original contrast.

7. Repeat step 2. through step 6. using the Bias option.

8. When you are finished, click Close in the Shift/Bias Adjustment dialog.

Use Mouse Linear 
Mapping

1. In the Breakpoint Editor, click the Red Mouse Linear Mapping icon  
, which is located on the left border of the Red histogram.

The Red Mouse Linear Mapping dialog opens.

Shift moves the 
lookup table graph
left and right 
(X direction)

Bias moves the
lookup table graph
up and down
(Y direction)

Use Mouse Linear 
Mapping

Do this at a later
occasion

In the Breakpoint Editor, click the Red Mouse Linear Mapping icon
, which is located on the left border of the Red histogram.

The Red Mouse Linear Mapping dialog opens.
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